Library Fixed and Other Changes

The library issues I was having appear to be resolved. When I upgraded WordPress, I simply overwrote the existing files (‘cuz I’m lazy) and then I went into my permalink settings and hit the update button (without actually making any changes). This is supposed to be enough to get the plugin I use for the library to reset the permalinks but that didn’t happen this time. I ended up deleting all of WordPress’ core file, re-uploading them, changing my webhost’s configuration to support PHP5, upgrading to the very latest copy of the plugin and re-saving my permalink settings before I was able to get the library working correctly again.

Other Changes

I also noticed when I upgraded/changed themes last time I forgot to add back in the magic codes to have ads from Google AdSense appear in a couple of places on my site. Those are ads are now back, though I do use another plugin to hide them from regular readers and on current content. Basically, if you are just stopping by (e.g. found me via a search engine) you will see ads. If you’ve been here a few times in the past couple of weeks, then you most likely won’t. Mind you these ads aren’t making me rich1, but they do help offset the costs of my online addiction webhosting.

New Theme

Yeah, I wasn’t a big fan of the previous theme I was using but it was good enough for a short term solution. The current theme2 is better but still needs more tweaks to make it mine. Things are likely to be in a state of flux until further notice around here. Things I still need to do:

  • Add one or more random photos to the sidebar or possibly the footer.
  • Work up a better header image.
  • Style the footer more to my liking.
  • Fix the sidebar formatting issues in IE3

1 I haven’t even had enough clicks on the silly Google AdSense ads to get paid yet
2 In case you happen to be curious, it’s a slightly tweaked version of the Shades of Gray style for the Sandbox theme.
3 Odds of this happening are tiny. I only use IE at work and then only rarely. If the slight offsets in the sidebar offends your design sensibilites, get Firefox!

4 Comments

Comments are closed.

Out of interest, what do you have as your permalink structure?

I too have upgraded to WP 2.5 and my library links have all gone for a burton.

I can’t even remember what my permalink structure was….

boo hoo!

If you just upgraded and your permalinks aren’t working with the Now-Reading plugin, you should be able to just go into WP-Admin -> Settings -> Permalinks and click on “Save Changes”. That should refresh all your permalinks and get the Now-Reading permalinks working again.

To more directly answer your question, I use: /archives/%year%/%monthnum%/%day%/%postname%/ for my WP permalinks and have Now-Reading setup as: “Use mod_rewrite enhanced library?” = Yes and “Permalink base: http://coffeebear.net/” = “library/”

Thanks

I’ve tried just about everything, and I just can’t get it working. I’ve poasted on Rob’s forum to see if anyone had any suggestions.

I’ve updated the Permalinks settings, and the Now Reading settings. I’m tearing my hair out :)

I wasn’t quite sure what you meant by the last bit above – where do you put the “Permalink base: http://coffeebear.net/” = “library/” setting?

[...] CoffeeBear.net « Library Fixed and Other Changes [...]

Copyright © 2004 – 2014 CoffeeBear.net. Powered by WordPress.

Creative Commons License